Page updated Jan 16, 2024

Use existing AWS resources

Amplify iOS v1 is now in Maintenance Mode until May 31st, 2024. This means that we will continue to include updates to ensure compatibility with backend services and security. No new features will be introduced in v1.

Please use the latest version (v2) of Amplify Library for Swift to get started.

If you are currently using v1, follow these instructions to upgrade to v2.

Amplify libraries should be used for all new cloud connected applications. If you are currently using the AWS Mobile SDK for iOS, you can access the documentation here.

Existing Amazon Pinpoint resources can be used with the Amplify Libraries by referencing your Application ID and Region in your amplifyconfiguration.json file.

{ "analytics": { "plugins": { "awsPinpointAnalyticsPlugin": { "pinpointAnalytics": { "appId": "[APP ID]", "region": "[REGION]" }, "pinpointTargeting": { "region": "[REGION]" } } } } }
1{
2 "analytics": {
3 "plugins": {
4 "awsPinpointAnalyticsPlugin": {
5 "pinpointAnalytics": {
6 "appId": "[APP ID]",
7 "region": "[REGION]"
8 },
9 "pinpointTargeting": {
10 "region": "[REGION]"
11 }
12 }
13 }
14 }
15}
  • pinpointAnalytics
    • appId: Amazon Pinpoint application ID
    • region: AWS Region where the resources are provisioned (e.g. us-east-1)
  • pinpointTargeting
    • region: AWS Region where the resources are provisioned (e.g. us-east-1)

Note that before you can add an AWS resource to your application, the application must have the Amplify libraries installed. If you need to perform this step, see Install Amplify Libraries.